Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How do I enable restricted headers with HTTPClient

Hi I'm running SDC 3.10.1 in a Docker container (the streamsets/datacollector:3.10.1 image) I am trying to make an HTTP call with HTTPClient using a restricted header like following:

curl -X GET -H "Host: my-host" http://my-service/my-endpoint

but my header is by default ignored with the warning:

'HttpUrlConnector - Attempt to send restricted header(s) while the [sun.net.http.allowRestrictedHeaders] system property not set. Header(s) will possibly be ignored'

Where do I have to put this system property to? Adding it in my 'sdc.properties' didn't fix my problem. Thank you in advance!

How do I enable allow restricted headers with HTTPClient

Hi I'm running SDC 3.10.1 in a Docker container (the streamsets/datacollector:3.10.1 image) I am trying to make an HTTP call with HTTPClient using a restricted header like following:

curl -X GET -H "Host: my-host" http://my-service/my-endpoint

but my header is by default ignored with the warning:

'HttpUrlConnector - Attempt to send restricted header(s) while the [sun.net.http.allowRestrictedHeaders] system property not set. Header(s) will possibly be ignored'

Where do I have to put this system property to? Adding it in my 'sdc.properties' didn't fix my problem. Thank you in advance!