Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

MySQL to Apache Phoenix

Does StreamSets DC support migrate data from MySQL to Apache Phoenix directly?

MySQL to Apache Phoenix

Does StreamSets DC support migrate migrating data from MySQL to Apache Phoenix directly?

After trying with JDBC Producer destination, the data pipeline reports the following error:

JDBC_00 - Cannot connect to specified database: com.zaxxer.hikari.pool.PoolInitializationException: Exception during pool initialization: org.apache.hadoop.hbase.DoNotRetryIOException: java.lang.IllegalAccessError: tried to access method com.google.common.base.Stopwatch.<init>()V from class org.apache.hadoop.hbase.zookeeper.MetaTableLocator

I added the following jars in sdc-extras/streamsets-datacollector-jdbc-lib/lib directory:

  • mysql-connector-java-5.1.42-bin.jar
  • commons-configuration-1.6.jar
  • hbase-common-1.2.3.jar
  • phoenix-core-4.11.0-HBase-1.2.jar
  • hadoop-auth-2.5.1.jar
  • zookeeper-3.4.6.jar
  • hadoop-common-2.7.1.jar
  • phoenix-4.11.0-HBase-1.2-client.jar
  • hbase-client-1.2.3.jar
  • phoenix-4.11.0-HBase-1.2-thin-client.jar

Any idea how to fix it?

MySQL to Apache Phoenix

Does StreamSets DC support migrating data from MySQL to Apache Phoenix directly?

After trying with JDBC Producer destination, the data pipeline reports the following error:

JDBC_00 - Cannot connect to specified database: com.zaxxer.hikari.pool.PoolInitializationException: Exception during pool initialization: org.apache.hadoop.hbase.DoNotRetryIOException: java.lang.IllegalAccessError: tried to access method com.google.common.base.Stopwatch.<init>()V from class org.apache.hadoop.hbase.zookeeper.MetaTableLocator

I added the following jars in sdc-extras/streamsets-datacollector-jdbc-lib/lib sdc-extras/streamsets-datacollector-jdbc-lib/lib directory:

  • mysql-connector-java-5.1.42-bin.jar
  • commons-configuration-1.6.jar
  • hbase-common-1.2.3.jar
  • phoenix-core-4.11.0-HBase-1.2.jar
  • hadoop-auth-2.5.1.jar
  • zookeeper-3.4.6.jar
  • hadoop-common-2.7.1.jar
  • phoenix-4.11.0-HBase-1.2-client.jar
  • hbase-client-1.2.3.jar
  • phoenix-4.11.0-HBase-1.2-thin-client.jar

Any idea how to fix it?