Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

upgrade StreamSets from 3.3 to 3.7

We are currently on mapr 6.0.1 with Streamsets 3.3. I want to upgrade to v3.7 and am getting an error during start up 2019-01-14 21:07:27,494 [user:] [pipeline:] [runner:] [thread:main] WARN AbstractTask - Task 'pipelineNode' failed to initialize, java.lang.RuntimeException: There cannot be 2 different versions of the same stage: [Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='1' Library='streamsets-datacollector-cdh_kafka_2_0-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-hdp_2_6-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-cdh_kafka_3_0-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-apache-kafka_1_0-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-apache-kafka_0_11-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='1' Library='streamsets-datacollector-apache-kafka_0_9-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='1' Library='streamsets-datacollector-apache-kafka_0_10-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-mapr_6_0-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='1' Library='streamsets-datacollector-hdp_2_5-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-cdh_kafka_2_1-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-apache-kafka_1_1-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-apache-kafka_2_0-lib', .......

we have the following installed. mapr-kafka-1.0.1.201803222228-1.noarch mapr-librdkafka-0.11.3.201803231414-1.noarch

Any Advice? How do i revert to v3.3?

upgrade StreamSets from 3.3 to 3.7

We are currently on mapr 6.0.1 with Streamsets 3.3. I want to upgrade to v3.7 and am getting an error during start up up

2019-01-14 21:07:27,494 [user:] [pipeline:] [runner:] [thread:main] WARN  AbstractTask - Task 'pipelineNode' failed to initialize, java.lang.RuntimeException: There cannot be 2 different versions of the same stage: [Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='1' Library='streamsets-datacollector-cdh_kafka_2_0-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-hdp_2_6-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-cdh_kafka_3_0-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-apache-kafka_1_0-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-apache-kafka_0_11-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='1' Library='streamsets-datacollector-apache-kafka_0_9-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='1' Library='streamsets-datacollector-apache-kafka_0_10-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-mapr_6_0-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='1' Library='streamsets-datacollector-hdp_2_5-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-cdh_kafka_2_1-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-apache-kafka_1_1-lib', Stage='com_streamsets_pipeline_stage_origin_multikafka_MultiKafkaDSource' Version='2' Library='streamsets-datacollector-apache-kafka_2_0-lib',  ..............

We have the following installed:

we have the following installed.

mapr-kafka-1.0.1.201803222228-1.noarch
mapr-librdkafka-0.11.3.201803231414-1.noarch

mapr-librdkafka-0.11.3.201803231414-1.noarch

Any Advice? How do i revert to v3.3?