Ask Your Question
0

Ubuntu User setting on MapR

asked 2018-01-09 05:52:36 -0600

davidha gravatar image

Hello, I installed Streamsets on Ubuntu 14.0LTS. I am trying to pipe data to MapR FS destination. The MapR prerequisite seem to be okay since I am able to find MapR FS origin and Destination in Streamsets and I am able to use Streamsets to pipe data to MapR FS as well. The problem I encounter is that I can only pipe data to directory with 777 permission, for instance, the default /tmp/ directory works fine. For other directories created by "mapr" user, with 755 permission, write permission denied error pop up.

I tried to change the Hadoop FS User parameter to "mapr", seems no significant difference. To make the directory works, I need to change the permission to 777 again. So I would like to know about how the user setting for this use case works?

Another information is that we are starting sdc with "usera" manually (usera$:bin/streamsets dc). So I suspect that the actual pipeline will be executed by "usera" making me failed to pipe data to MapRFS directory created by "mapr" user. However, even I change the MapRFS directory owner "usera", I still got the error. Is there anything I missed or can check ?

David

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-01-10 22:58:04 -0600

Mufy gravatar image

Keeping SDC aside, what's your observation if you were to try and copy/move a file to the same SDC MapR-FS destination that complaints with the error? Somehow, the behavior rings a bell that I have come across with MapR in the past - with respect to permissions/ACLs not set right on the target object.

Do you have any ACEs applied on the destination on MapR-FS? What do they look like? Please share a sample - both regular permissions and the ACEs.

edit flag offensive delete link more

Comments

It happens if I use sudo -u mapr bin/streamsets dc to start services, the I will be able to write data to the destination, so the current situration feels like the Hadoop FS user parameter does not make a difference. The ACE is just as default(u:mapr) for the volume and permission is 755 mapr:mapr

davidha gravatar imagedavidha ( 2018-01-11 19:50:22 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-01-09 05:52:36 -0600

Seen: 19 times

Last updated: Jan 10