Ask Your Question
0

jython evaluator errors: module object has no attribute _condition [closed]

asked 2020-07-25 03:50:47 -0500

tetemes gravatar image

updated 2020-07-26 23:07:15 -0500

Hi,

No matter what I do in Jython Evaluator, I keep getting this error in preview: Script sent record to error: 'module' object has no attribute '_Condition'

This happens even if there is only one import in the script What does this error mean? How can I avoid it?

Edit adding code:

 import sys
 sys.path.append('/lib/python2.7/site-packages')
 import boto3
 client = boto3.client('s3')
 for record in sdc.records:
   try:
     pass
 except Exception as e:
   sdc.error.write(record, str(e))

I was so frustrated, I did not think. Now I tested, and boto3.client() is the cause of this error message. I think I will close this question and continue with checking the boto3 module if it can be updated or I could use another function.

Thank you

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tetemes
close date 2020-07-28 15:32:21.929823

Comments

Update your question and add your code snippet as well other details about your pipeline.

iamontheinet gravatar imageiamontheinet ( 2020-07-26 10:34:57 -0500 )edit

Thank you, I edited the question. Please see above.

tetemes gravatar imagetetemes ( 2020-07-26 23:07:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-07-28 13:37:00 -0500

iamontheinet gravatar image

Yes, I would look into installing all the dependencies for boto3 as well.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2020-07-25 03:50:47 -0500

Seen: 47 times

Last updated: Jul 26