Ask Your Question

Elasticsearch destination: listener timeout after waiting for [30000] ms

asked 2020-02-11 10:35:57 -0600

Pankaj gravatar image

updated 2020-02-11 13:30:26 -0600

metadaddy gravatar image

Hi, I am ingesting records to Elasticsearch. When I increase batch size to 10000, I am getting this error:

ELASTICSEARCH_17 - Could not index '10000' records: listener timeout after waiting for [30000] ms

However, it's working fine for 1000 records. Could you please help me. I am stuck here.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2020-02-11 13:29:37 -0600

metadaddy gravatar image

It sounds like Elasticsearch can index somewhere between 1000 and 10000 records in the 30 seconds before the listener times out. It is not currently possible to set the listener timeout in the Elasticsearch destination. You should adjust the batch size so that you do not see this error.

edit flag offensive delete link more



Thank you for your quick response.

Pankaj gravatar imagePankaj ( 2020-02-11 20:50:31 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2020-02-11 10:27:23 -0600

Seen: 30 times

Last updated: Feb 11