Ask Your Question
1

AWS/PostgreSQL Connection String

asked 2019-12-09 18:27:55 -0600

txcs43vr gravatar image

updated 2019-12-10 12:30:09 -0600

metadaddy gravatar image

I am using Streamsets to connect to AWS/RDS/PostgreSQL. Here is my conn str

jdbc:postgresql://[ENDPOINT NAME]:[PORT]/[DATABASE]

and the error:

JDBC_00 - Cannot connect to specified database: com.zaxxer.hikari.pool.HikariPool$PoolInitializationException: Failed to initialize pool: FATAL: no pg_hba.conf entry for host "10.0.33.52", user "xxx", database "xxx", SSL off 2

Any suggestion?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2019-12-09 23:16:49 -0600

iamontheinet gravatar image

updated 2019-12-10 12:29:37 -0600

metadaddy gravatar image

Try adding 'sslmode=require' at the end of your connection string like so, jdbc:postgresql://[HOSTNAME]:[PORT]/[DBNAME]?sslmode=require

edit flag offensive delete link more

Comments

what is the syntax? there is a typo in your string is this what you suggested? jdbc:postgresql://[HOSTNAME]:[PORT]/[DBNAME]& sslmode=require

txcs43vr gravatar imagetxcs43vr ( 2019-12-10 11:51:15 -0600 )edit

Syntax is in my answer :) No '&' or space before ?sslmode=require.

iamontheinet gravatar imageiamontheinet ( 2019-12-10 11:52:59 -0600 )edit
1

This string works: jdbc:postgresql://[HOSTNAME]:[PORT]/[DBNAME] ?sslmode=require Thank you

txcs43vr gravatar imagetxcs43vr ( 2019-12-10 12:16:22 -0600 )edit

You're welcome!

iamontheinet gravatar imageiamontheinet ( 2019-12-10 12:39:13 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-12-09 18:27:55 -0600

Seen: 114 times

Last updated: Dec 10 '19