Ask Your Question
0

upgraded issue

asked 2019-11-15 12:33:02 -0600

Bharath_Thatikonda gravatar image

Team

we have upgraded streamsets version and we see all the pipelines are stopped.

below is the error. It would be great if some one can help

"container_0902 defination requires atleast version 16 which is higher than available library 12". i understand we are using older libraries. How can we upgrade them?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-11-15 13:54:53 -0600

jeff gravatar image

This really sounds like you have multiple versions of the same stagelib hanging around on disk, possibly side by side. Did you follow the upgrade instructions precisely? I recommend copying your data directory (which contains the pipelines) to somewhere safe, then doing a clean install of the newest SDC version, then importing them into that.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-11-15 12:33:02 -0600

Seen: 38 times

Last updated: Nov 15