Ask Your Question
1

Streamsets supports AMQP 1.0?

asked 2019-05-02 01:26:40 -0500

set92 gravatar image

How do I know that StreamSets supports AMQP 1.0? Because NiFi says in the documentation that only supports 0.9. But I couldn't find it in StreamSets, and I think that using RabbitMQ is easy to activate it via a plugin, but not sure if Streamsets added this plugin.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2019-05-02 12:30:02 -0500

iamontheinet gravatar image

updated 2019-05-02 12:37:56 -0500

metadaddy gravatar image

Hi!

It appears that StreamSets supports RabbitMQ version 3.5.6 and according to RabbitMQ's Changelog, support for AMQP 1.0 was added in RabbitMQ version 3.7.0. So to answer your question, StreamSets currently supports AMQP 0.9.

If you require AMQP 1.0, please file an issue and we can look at it for a future release.

Hope this helps.

Cheers, Dash

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-05-02 01:26:40 -0500

Seen: 45 times

Last updated: May 02