MySQL BinLog does not process any data

asked 2019-01-24 11:26:00 -0600

khorevr gravatar image

updated 2019-01-24 13:17:09 -0600

metadaddy gravatar image

MySQL version 5.6.42 on windows connect MySQL BinLog origin do insert on MySQL

the record exists in the log

'DS-XXX-XXXX-bin.000016', '199', 'Query', '1', '351', 'use `test`; INSERT INTO `test`.`table_test_1` (`RowID`, `F1`, `F2`) VALUES (\'7\', \'a\', \'a\')'

origin does not process any data. Record count in input = 0. Log:

 2019-01-24 17:07:20,055    test1/fef9500d6db-c55b-4234-a147-0c8ac7cd1189   INFO    HikariPool-973 - is starting.   HikariDataSource    *admin      ProductionPipelineRunnable-fef9500d6db-c55b-4234-a147-0c8ac7cd1189-test1
2019-01-24 17:07:20,236 test1/fef9500d6db-c55b-4234-a147-0c8ac7cd1189   INFO    Connected to 192.168.X.X:3306 at DS-XXX-XXXXXX-bin.000016/120 (sid:999, cid:1958)   BinaryLogClient *admin      blc-192.168.X.X:3306
2019-01-24 17:07:20,238 test1/fef9500d6db-c55b-4234-a147-0c8ac7cd1189   INFO    Connected client with configuration: MysqlSourceConfig{hostname='192.168.X.X', port=3306, username='test', password='**********', serverId=999, maxBatchSize=1000, maxWaitTime=1000, startFromBeginning=true, offset=}
edit retag flag offensive close merge delete

Comments

Have you tried resetting the pipeline offset?

metadaddy gravatar imagemetadaddy ( 2019-01-24 13:18:00 -0600 )edit

tried to set offset instead "startFromBegining",no success Connected client with configuration: MysqlSourceConfig{hostname='192.168.X.X', port=3306, username='test', password='**********', serverId=999, maxBatchSize=1000, maxWaitTime=1000, startFromBeginning=false, offset='DS-XXX-XXXXX-bin.000016:0

khorevr gravatar imagekhorevr ( 2019-01-24 17:54:47 -0600 )edit

maybe something is missing in the configuration tab of the origin? Tables in scope, min batch records, something else? Is somewhere step-by-step guide for configuration pipeline from MySQL to somewhere?

khorevr gravatar imagekhorevr ( 2019-01-26 00:52:39 -0600 )edit