Ask Your Question
0

HTTPS request to IP address using HTTP Client

asked 2017-10-17 21:59:55 -0600

Invigor gravatar image

updated 2017-10-18 13:22:11 -0600

metadaddy gravatar image

I'm trying to call an API which has an IP address and port for the end point and also requires the request to be made using HTTPS.

I can call it successfully using CURL but need to use the -k/--insecure option to turn off verification of the certificate.

Is there a setting in the HTTP Client connection I need to change to allow this to work correctly?

It is difficult to tell exactly what is happening at the moment. If I run TCPDUMP it looks like StreamSets is calling making large numbers of TCP requests every second. Probably trying to establish the SSL connection...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-10-23 16:15:23 -0600

Jerry gravatar image

The default protocol is in HTTP. User can disable HTTP and enable HTTPs in ../etc/sdc.properties, add cert to local keystore. It enables HTTPs connectivity.

For example, in sdc.properties, Change "http.port=18630" to "http.port=-1"; Change "https.port=-1" to "https.port=18630";

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-17 21:59:55 -0600

Seen: 103 times

Last updated: Oct 18 '17