Ask Your Question
0

Changing admin credentials with form-realm.properties

asked 2018-10-12 07:04:40 -0600

Hassan gravatar image

I've successfully installed StreamSets with the Clouder Manager on my CentOS 7 Host. The standard password for user admin is admin. Unfortunately I'm not able to change the admin password or add new users over the Web-GUI.

What I did so far:

  • Stopped StreamSets role with Cloudera Manager
  • Deleted all folder under /run/cloudera-scm-agent/process/*-streamsets-DATACOLLECTOR/
  • Commented out standard users and added new user to file form-realm.properties under /opt/cloudera/parcels/STREAMSETS_DATACOLLECTOR/etc/
  • Restarted StreamSets service with Cloudera Manager

After starting the service via Cloudera Manager I can see inside logs that StreamSets uses the same standard users like in the first installation

CONFIGURED_USERS: admin: MD5:21232f297a57a5a743894a0e4a801fc3,user,admin;guest: MD5:084e0343a0486ff05530df6c705c8bb4,user,guest;creator: MD5:ee2433259b0fe399b40e81d2c98a38b6,user,creator;manager: MD5:1d0258c2440a8d19e716292b231e3190,user,manager

Any suggestions how to change the standard user credentials?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-10-16 04:55:07 -0600

Hassan gravatar image

I've installed StreamSets now with the *.rpm-File and everything seems to work regarding changing credentials. Maybe there is a bug in the cloudera parcel?

edit flag offensive delete link more
0

answered 2018-10-14 21:16:44 -0600

Maithri gravatar image
edit flag offensive delete link more

Comments

Hello, As I described in my post, I did exactly the same steps. But unfortunately after restarting StreamSets with Cloudera Manager, StreamSets uses the same passwords like after the first installation. Thanks!

Hassan gravatar imageHassan ( 2018-10-15 01:55:49 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-12 07:04:40 -0600

Seen: 49 times

Last updated: Oct 16