Ask Your Question

JDBC Producer: Table does not exist or PDB is incorrect [closed]

asked 2018-10-03 06:20:50 -0500

Gaur gravatar image

updated 2018-10-04 23:36:43 -0500

Shruthi gravatar image

Hello, I'm pulling data from IBM DB2 using JDBC Consumer and writing to SAP HANA using JDBC Producer but getting error message "Table 'xxxxx' does not exist or PDB is incorrect. Make sure the correct PDB was specified". I have tried lower case, upper case table names and by just pulling one column but it doesn't work. All records are landing in error records output. Appreciate direction. BR//Gaur

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Gaur
close date 2018-12-06 02:45:37.185249


How did you configure JDBC Producer ?

Shruthi gravatar imageShruthi ( 2018-10-03 23:29:53 -0500 )edit

Pretty much same as yours. Cant attach a link, just learned I need >10 points for that lol Here are the details: JDBC Connection String: jdbc:sap://$host$:port/$Schemaname$ Schema Name: $Schemaname$ Table Name: Project Column: id SDC Field: /id Data Type: INTEGER

Gaur gravatar imageGaur ( 2018-10-04 01:56:17 -0500 )edit

I have updated my answer please check

Shruthi gravatar imageShruthi ( 2018-10-05 00:17:30 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-10-04 00:20:37 -0500

Shruthi gravatar image

updated 2018-10-05 00:16:07 -0500

Configure 'JDBC Producer' as following, image description

You need to check few things here:

  1. Does the table 'Project' exist? You should create the table in the mentioned DB before running the pipeline. JDBC will not create it. Also name your table in small letters(change 'Project' to 'project')
  2. Check you JDBC driver matches the server. Use 5.1.x driver.
  3. Try not to set anything in the 'Schema Name' configuration in the JDBC Producer, let this be blank since you are setting schemaname/database in the 'JDBC connection string'.

Refer for more details

edit flag offensive delete link more


Thanks for your reply. I have tried by creating table in target in small and capital letter both but didn't help. driver and schema name setting as you mentioned didnt help either. BR//Gaur

Gaur gravatar imageGaur ( 2018-10-08 05:41:32 -0500 )edit

Question Tools



Asked: 2018-10-03 06:20:50 -0500

Seen: 1,335 times

Last updated: Oct 05 '18