Ask Your Question
1

Data preview only showing 10 records

asked 2018-09-18 05:08:30 -0500

eohehirA gravatar image

Hi,

I am trying to see 100 records in the data preview, but can only see 10 records.

Is there a way to see more than 10 records ?

I have tried this on different pipelines but 10 seems to be the maximum number of records available.

I configure the data preview as follows:

Preview Source: Configured Origin

Preview Batch Size: 100

Preview Timeout: 30000

Write to Destination Executors: Unchecked

Execute pipeline lifecycle events: Unchecked

Show Record/Field Header: Checked

Show Field Type: Checked

Remember the configuration: Unchecked

Thanks,

Eoin.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-09-18 09:37:17 -0500

iamontheinet gravatar image

Hi!

The pipeline preview batch size is capped at the Data Collector's preview batch size--which is set to 10 by default. So in order to increase pipeline preview batch size you'll first need to change Data Collector's preview batch size by editing preview.maxBatchSize property in sdc.properties file. (Note: for the change to take effect you'll need to restart Data Collector.)

Cheers, Dash

edit flag offensive delete link more

Comments

That worked. Thanks.

eohehirA gravatar imageeohehirA ( 2018-09-19 04:18:50 -0500 )edit

You're welcome!

iamontheinet gravatar imageiamontheinet ( 2018-09-19 11:37:51 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-09-18 05:08:30 -0500

Seen: 25 times

Last updated: Sep 18