Ask Your Question
0

Error Starting Streamsets on A MapR Cluster

asked 2018-06-12 04:03:13 -0500

seamfaces gravatar image

updated 2018-06-12 05:33:28 -0500

Hello Everyone,

I just upgraded my MapR Cluster and I am trying to start Streamsets. However I get the following Error:

Exception in thread "main" java.lang.ExceptionInInitializerError: Expected exactly 1 stage lib jar but found 0 with name streamsets-datacollector-mapr_6_0-mep4-lib Jun 12 09:48:56 BGDTEST5 streamsets[24543]: at com.streamsets.pipeline.SDCClassLoader.bringStageAndProtoLibsToFront(SDCClassLoader.java:186) Jun 12 09:48:56 BGDTEST5 streamsets[24543]: at com.streamsets.pipeline.SDCClassLoader.getOrderedURLsForClassLoader(SDCClassLoader.java:404) Jun 12 09:48:56 BGDTEST5 streamsets[24543]: at com.streamsets.pipeline.SDCClassLoader.<init>(SDCClassLoader.java:119) Jun 12 09:48:56 BGDTEST5 streamsets[24543]: at com.streamsets.pipeline.SDCClassLoader.getStageClassLoader(SDCClassLoader.java:389) Jun 12 09:48:56 BGDTEST5 streamsets[24543]: at com.streamsets.pipeline.SDCClassLoader.getStageClassLoader(SDCClassLoader.java:383) Jun 12 09:48:56 BGDTEST5 streamsets[24543]: at com.streamsets.pipeline.BootstrapMain.main(BootstrapMain.java:291) Jun 12 09:48:56 BGDTEST5 systemd[1]: sdc.service: main process exited, code=exited, status=1/FAILURE Jun 12 09:48:56 BGDTEST5 systemd[1]: Unit sdc.service entered failed state. Jun 12 09:48:56 BGDTEST5 systemd[1]: sdc.service failed.

I can see the stage-lib in question in the streamsets-libs directory. This used to work seamlessly before. Please what am I doing wrong and this is very urgent

edit retag flag offensive close merge delete

Comments

Can you add details on the versions you upgraded MapR from/to?

metadaddy gravatar imagemetadaddy ( 2018-06-12 09:20:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-06-12 10:34:45 -0500

kirti gravatar image

updated 2018-06-12 11:19:15 -0500

1) Which version of StreamSets DataCollector is in use?

2) Since you upgraded MapR cluster, would you please once again try to make sure all the prerequisites are met for the new version? https://streamsets.com/documentation/datacollector/latest/help/#datacollector/UserGuide/Installation/MapR-Prerequisites.html#concept_jgs_qpg_2v

Especially looking at the error it seems the relevant section is Step 2. Run the Command to Set Up MapR

3)Can you see the very stage_lib through StreamSets DataCollector UI?

4)Which method (rpm or tar or ?) did you use to install StreamSets DataCollector?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-12 04:03:13 -0500

Seen: 10 times

Last updated: Jun 12