Ask Your Question

Getting "Jetty ALPN/NPN" error on Google Pub/Sub validation

asked 2018-02-22 12:15:00 -0500

mwall gravatar image

updated 2018-02-22 13:41:59 -0500

metadaddy gravatar image

I have a Google Pub/Sub Processor. I have entered in all the correct information. But when I validate, it returns an error on the Credentials tab.

PUBSUB_04 - Error validating permissions: 'java.lang.IllegalArgumentException: Jetty ALPN/NPN has not been properly configured.'

I am using service account credentials file.

2018-02-22 18:08:00,334 [user:*admin] [pipeline:EPC_Google_pub_sub/EPCGooglepubsubc373890b-eb38-4d05-b001-21a367e20f24] [runner:] [thread:preview-pool-1-thread-3] ERROR PubSubSource - Error validating permissions: 'java.lang.IllegalArgumentException: Jetty ALPN/NPN has not been properly configured.'
java.lang.IllegalArgumentException: Jetty ALPN/NPN has not been properly configured.
        at io.grpc.netty.GrpcSslContexts.selectApplicationProtocolConfig(
        at io.grpc.netty.GrpcSslContexts.configure(
        at io.grpc.netty.GrpcSslContexts.configure(
        at io.grpc.netty.GrpcSslContexts.forClient(
        at io.grpc.netty.NettyChannelBuilder$NettyTransportFactory$DefaultNettyTransportCreationParamsFilterFactory.<init>(
        at io.grpc.netty.NettyChannelBuilder$NettyTransportFactory$DefaultNettyTransportCreationParamsFilterFactory.<init>(
        at io.grpc.netty.NettyChannelBuilder$NettyTransportFactory.<init>(
        at io.grpc.netty.NettyChannelBuilder.buildTransportFactory(
        at com.streamsets.pipeline.stage.pubsub.origin.PubSubSource.testPermissions(
        at com.streamsets.pipeline.stage.pubsub.origin.PubSubSource.init(
        at com.streamsets.pipeline.api.base.BaseStage.init(
        at com.streamsets.pipeline.configurablestage.DStage.init(
        at com.streamsets.datacollector.runner.StageRuntime.lambda$init$0(
        at com.streamsets.datacollector.util.LambdaUtil.withClassLoaderInternal(
        at com.streamsets.datacollector.util.LambdaUtil.withClassLoader(
        at com.streamsets.datacollector.runner.StageRuntime.init(
        at com.streamsets.datacollector.runner.StagePipe.init(
        at com.streamsets.datacollector.runner.StagePipe.init(
        at com.streamsets.datacollector.runner.Pipeline.initPipe(
        at com.streamsets.datacollector.runner.Pipeline.init(
        at com.streamsets.datacollector.runner.Pipeline.validateConfigs(
        at com.streamsets.datacollector.runner.preview.PreviewPipeline.validateConfigs(
        at com.streamsets.datacollector.execution.preview.sync.SyncPreviewer.validateConfigs(
        at com.streamsets.datacollector.execution.preview.async.AsyncPreviewer$
        at com.streamsets.pipeline.lib.executor.SafeScheduledExecutorService$SafeCallable.lambda$call$0(
        at com.streamsets.pipeline.lib.executor.SafeScheduledExecutorService$
        at com.streamsets.pipeline.lib.executor.SafeScheduledExecutorService$SafeCallable.lambda$call$0(
        at com ...
edit retag flag offensive close merge delete


Is that the full stack trace? There is no further exception below this?

jeff gravatar imagejeff ( 2018-02-22 16:13:34 -0500 )edit

Hi Jeff, Yes. that is the entire Exception.

mwall gravatar imagemwall ( 2018-02-22 16:49:51 -0500 )edit

Which exact SDC version are you using? And was this pipeline working on a previous version (if so, which point version)?

jeff gravatar imagejeff ( 2018-02-23 09:57:11 -0500 )edit

SDC Version: ( built by root on 2018-02-08T19:04Z git: afdbb4a51451e4a78cc603e9064fedf419fa0271) JDK version "1.8.0_161" Red Hat 4.8.5-16 - Linux version 3.10.0-693.17.1.el7.x86_64 New OS and system. Don't know if an earlier version would have worked. Used the rpm installation.

mwall gravatar imagemwall ( 2018-02-23 11:03:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-02-23 17:19:36 -0500

mwall gravatar image

This is now fixed. There was another entry in the log file.

            INFO  NativeLibraryLoader - /tmp/ exists but cannot be executed even when execute permissions set; check volume for "noexec" flag; use -Dio.netty.native.workdir=[path] to set native working directory separately.

After doing some research, the suggestion was to execute the below command

sudo mount /tmp -o remount,exec

After restarting sdc, I was able to validate the pipeline.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2018-02-22 12:15:00 -0500

Seen: 26 times

Last updated: Feb 23