Ask Your Question
1

HTTP proxy not being detected when running SDC in Docker

asked 2018-02-16 06:11:18 -0600

mikygit gravatar image

updated 2018-02-16 16:25:15 -0600

jeff gravatar image

I'm having trouble making sdc docker run.

I have a timeout issue. Tried to specify a proxy URL via -e but no luck.

I looked at the sdc.properties specs but did not find a way to specify a proxy url.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-02-16 16:24:39 -0600

jeff gravatar image

The HTTP proxy needs to be specified as a Java property when the JVM that runs SDC starts. The relevant JVM properties are http.proxyHost and Dhttp.proxyPort. See this section of the documentation for how to set Java Configuration Options (JVM arguments).

For the particular case outlined here (running in Docker), you would need to ensure the SDC_JAVA_OPTS environment variable is set when the Docker container is started, so that the JVM that runs SDC picks it up correctly upon startup. Hence, you will need to do something like docker run ... -e SDC_JAVA_OPTS="-Dhttp.proxyHost=X -Dhttp.proxyPort=Y" ... when starting the container.

edit flag offensive delete link more

Comments

It does not work for me unfortunately. I tried several solutions: yours, modifying sdc.properties and extending Streamsets Dockerfile but in vain. I'm still getting this timeout issue when it tries to download items from library. Any ideas what I could try next?

mikygit gravatar imagemikygit ( 2018-02-20 02:57:48 -0600 )edit

Actually, I do not get any error anymore but the stage library stays empty. Should I enter some repo URL or credentials to make it work?

mikygit gravatar imagemikygit ( 2018-02-20 03:32:13 -0600 )edit

Does not work for me on Firefox. Works fine on Chrome ...

mikygit gravatar imagemikygit ( 2018-02-21 06:50:12 -0600 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2018-02-16 06:11:18 -0600

Seen: 139 times

Last updated: Feb 21