Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Thanks for responding @jeff and @J3 I could fix it by setting this in "Advanced" tab

Cluster Callback URL = http://MY_IP:19630

Thanks for responding @jeff and @J3 I could fix it by setting this in "Advanced" tab

Cluster Callback URL = http://MY_IP:19630I had marked it as fixed, but now I am in fresh VM with fresh transformer, same issue has occurred. transformer.properties has only 1 updated line and that is:

transformer.base.http.url=http://MY_IP:19630

Thanks Alright, so I did more research, and here is the conclusion:

  1. @jeff @J3 - I am using http
  2. If I start transformer manually, I do not get any error and pipeline just works fine.
  3. If I start automatically with init.d, it throws the error

I understand that for responding @jeff init.d it uses from /etc/transformer/transformer.properties and @J3 I could fix for manual starts, it by setting this reads from $TRANSFORMER_DIST/etc, in "Advanced" tabmy case it is /opt/streamsets/streamsets-transformer-3.13.0/etc

I had marked it as fixed, but now I am in fresh VM with fresh transformer, same issue has occurred. transformer.properties has only 1 updated line and that is:both places base http url is set properly like this:

transformer.base.http.url=http://MY_IP:19630